Linux

How To Fix MySQL ERROR 1524 (HY000): Plugin 'auth_socket' Is Not Loaded In MySQL 5.7+

Posted by Weston Ganger on February 02, 2017

I was having weird issues with my Rails apps on MySQL 5.7+ and getting the error ERROR 1524 (HY000): Plugin 'auth_socket' is not loaded. Basically we need to set the authorization plugin back to mysql_native_password. What a pain.

In the mysql prompt enter the following lines:


use mysql;
update user set plugin="mysql_native_password";

flush privileges;

MySQL upgrades are super frustrating. This is just another sign that I would really love to be able to use MariaDB but maybe just for future projects.


Related External Links:


Posted in Linux and Tagged with mysql 


Want me to help develop your next project or application?

Contact Us

Specializing in Ruby-on-Rails, Javascript, Multi-Platform Electron Desktop Apps and Hybrid Cordova Mobile Apps.

Recommended Posts